System:
Compaq Presario 5660
Win98
450mhz/Pentium II
DVD-Rom
HP CD-Writer Plus 7200

I've tried everything I can think of, please help!

My system worked fine even after I installed my burner, and I used it for a few months and burned several CD's with no problems. Then, one day I put a CD into the DVD Rom and it gave me the following error message:

An exception 0E has occured at 0028 : FCB69000 in VxD ---. This was called from 0028 : C182EB48 in VxD scsihlp(03) + 00000508.

Nearly the same error is produced when I put a CD in the burner, or even let the machine boot with a CD in either of the drives.
I tried removing both drives under device manager, letting Windows re-recognize them again, but the problem still continues. Device manager says they are working properly, no conflicts. I tried to update drivers for both drives, but Windows says I already have optimal drivers. Have also run scandisk (no errors found) and scanreg/restore, but no luck. System file check found several corrupt files, all of which where fixed except for one file called EANMI.VXD. Could this be the culprit? My HDD is on one IDE port by itself, and the 2 CD drives are on the other. Took turns with diconnecting either cd drive from the r. cable and letting Windows auto-detect the other, but didn't help. Neither will play audio CD's, they give the same error.I even tried virus scanned with Norton--none of this has fixed the problem. Tech support at Compaq couldn't even fix the problem, any suggestions?

Please feel free to contact me via e-mail: bulldog23@angelfire.com

Thank You.