I recently purchased an Ezonics EZCam II USB camera. I installed it as instructed (drivers and software before plugging in the camera after restart) and once the camera was detected and drivers installed, it would not work. Upon checking in device mgr, I found the message 'the ntkern.vxd device loader(s) for this device could not load the device drivers (code 2). Sometimes out to the side this message also has vmm32.vxd in parenthesis.

I checked the Ezonics site and their help faq said the file is missing or corrupted and to uninstall the drivers (using a pgm from a folder that was never created and thus the file is not there) then reinstall.

I've manually uninstalled the drivers, reinstalled ntkern.vxd and vmm32vxd from the cab files as well as vflatd.vxd and vdd.vxd as suggested on another post here with no luck.

To make matters worse, a few of the components of my video card (All-in-Wonder Radeon) have the same error. They are:

ATI WDM Rage Theatre Video
ATI WDM Rage Theatre Audio
ATI WDM TV Audio Crossbar

and a couple of others I removed from device mananger and will probably have to reinstall the card to get back.

When I try to reinstall these drivers sometimes they will reinstall fine but I still get the error and sometimes I get a file opening error because ks.sys will try to copy itself from the cd to the cd.

I've tried everything I can think of and followed every bit of info I've been able to find anywhere. Anyone else got any suggestions?

My system stats are as follows:
750 mhz Athlon Thunderbird processor
Microstar K7T Pro 2A mainboard w/ 2 USB ports
128 mb ram
ATI All-in-Wonder Radeon 32 mb Video card
Phillips Seismic Edge Sound Card
cd-rw, dvd-rom
Network adapter

Thanks in advance for your help!

[This message has been edited by psibear (edited February 15, 2001).]