[RESOLVED] A Real Challenge -> Help Me Figure Out What Ails My Notebook!
Results 1 to 4 of 4

Thread: [RESOLVED] A Real Challenge -> Help Me Figure Out What Ails My Notebook!

  1. #1

    Arrow A Real Challenge -> Help Me Figure Out What Ails My Notebook!

    A Real Challenge -> Help Me Figure Out What Ails My Computer!

    A real challenge --> Discover what ails the HP Omnibook XE2 DC Notebook

    I imagine a preface is in order.. Whenever I configure a new DOS/Windows computer I always partition the HD with FDISK (FAT32) then FORMAT. I created C:\D:\E:\F:\G: (3GB, 560MB, 5GB, 5GB, 6GB) - (system drive 3GB, dedicated virtual memory drive = 560MB). The Win98se source files were on E: - My usual technique is to boot from DOS floppy with minimal drivers on it. Then launch the Setup.exe in the WIN98 directory.

    The last hundred times I did this with other computers the OS installs rather uneventfully and is followed by a dull hour or so of installing current drivers and tweaking settings for performance. Then I create a disk image follwed by installing the applications/programs.

    This time was very different..

    During the Win98se install, at about the time that Win98se installer looks at the hardware config, the notebook crashed - three times by the end of the install (all fatal exception errors accompanied by the dreaded blue-screen). I couldnt believe it, I've never seen anything like it so early in the progression of an OS install. I re-formatted and started from scratch a couple times, nothing made a difference, so I figured a rare instance of hardware failure, ran some tests and everything was fine - The notebook passed all of the Hardware diagnostics, including the RAM error tests. I then thought the BIOS was suspect, so I updated it to the latest version, released just a month ago. The CMOS is minimally configurable, like most portable CMOS's.
    All of the most current drivers were then installed.

    Now, mind you, I know a thing or two about computers, I could probably build a computer from raw silicon, hell, I might even be able to pull it off using silica in a pinch.. But I've never come across a problem like this. Usually the confilicts happen later in the game, when there is something to conflict with. Hence, my being suspect of hardware failure. BUT for the most part, the thing runs fine in Win98se 'Safe-Mode', which would be consistent of software being the culprit.

    Here's what I've done so far:

    - Set the CMOS to default settings (which were all reasonable)
    - Clean-booted, defeating system.ini, win.ini, config.sys, autoexec.bat, startup folder files
    - Run System File Checker
    - Run Windows Registry Checker
    - Checked for existence of a 'Winstart.bat' file - it does not exist.
    - Did another Win98se install into a clean folder using what switches I could remember to keep the installer from looking for hardware.
    - Troubleshot protected-mode driver problems, using msconfig's advanced settings.
    - I even tried disabling EVERY device in the device manager.
    - I ran the Automatic Skip Driver Agent (asd.exe)
    - I checked for damaged VxDs by booting and using the 'step-by-step' function and not loading any file that had a .vxd extension.
    - I checked my BOOTLOG.TXT file and confirmed I only had the usual failures (ndis2sup.vxd, SDVXD & VPD failing their initializations.

    And guess what? I can proudly say that I now enjoy a well-balanced mix of not only garden-variety exceptions but also fatal exceptions -- all sprinkled generously with frequent windows protection failures at bootup and/or shutdown. Oh yes, I lest I forget to mention the good-ol "Invalid VxD Dynamic Link Call" - which makes a cameo appearance on occasion.

    And I mean a lot of them, I can barely boot and launch a program without an exception and every other boot-up I have to hit the reset button because a protection error froze things.

    With the evidence of a reasonably-stable system when in 'Safe-Mode', I have to think my problems are not hardware. Maybe a poorly-written CMOS/BIOS.. ?


  2. #2


    Dont know if its any help but the English version Feb 2001 of PC PRO magazine has an install question listed in its Q&A section related to a fault during install the causes given are:
    HIMEM.SYS cant handle line A20
    DOS=HIGH is not working
    Your memmory has a fault
    EMM386.EXE NOEMS x=A000-EFFF line is missing fromCONFIG.SYS
    CMOS setup wrongly
    BIOS out of date
    Corrupted disk
    Virus i.e. Forms,Noint,Yankee doodle
    You are running DRDOS
    Wrongly configured memmory manager

    Best I can do

  3. #3


    Thanks Andi, some good stuff there, I've already covered some of that, but the modfier on EMM386 looks interesting, I'm going to try it!

    Thanks Again!

  4. #4

    Thumbs up

    Just one possibility,

    Have you disabled any save-to-disk or other power management stuff from the BIOS, and turned off any such management from the software side like Win98?
    The only other thing that I can think of is that HP require a "key" file on the HD to enable reinstallation of OS, this is certainly what Compaq do! All it is, is a file containing some sort of unlock code for the OS to reference, as Compaq supply all the software on a Quickinstall CD, and you don't get a Win98 CD at all!
    Try a low level format on the HD, this may also work.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts