[RESOLVED] Mouse doesn't drag/drop
Results 1 to 3 of 3

Thread: [RESOLVED] Mouse doesn't drag/drop

  1. #1

    Mouse doesn't drag/drop

    Lately, it seems my PC clients have been conspiring to drive me nuts...and they haven't far to go! THIS week's big puzzler regards a misbehaving mouse...

    My client called me in to repair his system. Seems he had some small problems and tried to repair them himself...by running the "Inbox Repair Tool" on EVERY .exe and .com file on his system! Needless to say, the PC would not even boot (Command.com just wasn't the same anymore...) and of course, there was NO backup. After about 5 hours of "joy", I had his system completely repaired! Windows ran, all his programs worked, it dialed out to the internet, printed...just one little nagging thing: the mouse does NOT "drag and drop". The "highlight" function does not work (click once on an icon on the desktop, and it does NOT change color), though you can right and left click with all normal functions in both Win95 and all programs. He had a "Genius" PS/2 style mouse (with a scrolling lever between the left/right buttons) installed. I uninstalled it, removed everything I could find for it in the registry, and tried rebooting with a clone mouse installed. Same symptoms with the Win95 mouse driver installed. So, I tried a generic serial mouse on the next boot-up. Same issue! I did some more clearing out of the registry, and lo and behold, the drag/drop reappeared! It even worked when his original mouse was installed. So I left to go home and rest my aching brain.

    Which was fine, until the next morning. Apparently, the drag/drop only worked for a few minutes! He went out onto the internet and after logging off, the drag/drop did not work. He rebooted the PC. Drag/drop came back...for a while. In continued use over the past few days, drag/drop has not returned.

    My client has just bought a new PC. He gave up. I'm stubborn. I still want to know what happened...

    Any ideas?

  2. #2
    Registered User CompuDocs's Avatar
    Join Date
    Mar 1999
    Loves Park, Illinois USA
    I have noticed this to be one of the problems of an unsuccessful uninstallation of Internet Explorer 4.

    Had the same problem, manually dug out IE4 from the file system and registry, re-ran Windows installation & A-OK. It's a pain getting IE4 out though.
    "Oh Bother," said Pooh, as Windows crashed for the umpteenth time.

  3. #3
    Registered User stevet's Avatar
    Join Date
    Oct 1998
    Coeur d'Alene, ID USA
    I ran into the same frustrations a few months ago. I kept trying to figure out why the bleeping mouse wouldn't drag and drop. Finally, I found out that the problem was caused by reinstalling Win95 (pre-C) on a system which had IE4 installed. Once Internet Explorer 4 has been installed on a Win95 machine, it must be uninstalled before doing a reinstall of Win95. Most Win95 versions will install either IE 2.0 or 3.0, which overwrites some important IE 4.0 files. Loss of drag and drop is one of the symptoms. You can search Microsoft support for an article on how to do a manual uninstall of IE4 from a DOS prompt. If you can't get into Windows to do a normal uninstall, then you will need to do a DOS uninstall before reinstalling Win95. There are several files that need to be renamed and a couple of files which need to be extracted from the Win95 .cab files. I created a batch file (I named it ie4nuke.bat) which will do this uninstall and I finally got to test it the other day and it worked great. Email me if you would like a copy.

    Navin: "The new phone book's here! The new phone book's here!"


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts