Wireless
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 30

Thread: Wireless

  1. #1
    Registered User BlueShadowDemon's Avatar
    Join Date
    Aug 2002
    Location
    West Tenesseee
    Posts
    105

    Wireless

    I have just recently installed Mandrake 9.1 and all is well except I cannot seem to get my Linksys Wireless USB adapter to work. I am new to Linux, and have been playing around on it for a while. If anyone can tell me what I need to do please say. I have checked Linksys for drivers and various other places with no luck.


    BSD
    Share on Google+

  2. #2
    Registered User +Daemon+'s Avatar
    Join Date
    Jan 2002
    Location
    RC, Ca
    Posts
    3,406
    you will have alot of trouble with this, there is not alot of support. and is very very hard to get working, I have a linksys wireless USB adapter also and I still cant get it to work... you will have to search online.
    Share on Google+

  3. #3
    Registered User +Daemon+'s Avatar
    Join Date
    Jan 2002
    Location
    RC, Ca
    Posts
    3,406
    if you want wireless to work under linux, I think you need the CISCO PCI wireless adpaters. The latest kernels have full support for those.
    Share on Google+

  4. #4
    Registered User BlueShadowDemon's Avatar
    Join Date
    Aug 2002
    Location
    West Tenesseee
    Posts
    105
    Thanks for your reply Daemon. I guess I will get the PCI adapter whenever I get the money, but I am still googling to see if I can get the USB to work.
    Share on Google+

  5. #5
    Registered User +Daemon+'s Avatar
    Join Date
    Jan 2002
    Location
    RC, Ca
    Posts
    3,406
    Originally posted by BlueShadowDemon
    Thanks for your reply Daemon. I guess I will get the PCI adapter whenever I get the money, but I am still googling to see if I can get the USB to work.
    if you do it let me know

    Im ganna need to buy a new via mobo anyways which will be running slackware 9 and im ganna try to get the Linksys wireless USB adapter to work too...well try again
    Share on Google+

  6. #6
    Registered User BlueShadowDemon's Avatar
    Join Date
    Aug 2002
    Location
    West Tenesseee
    Posts
    105

    Exclamation Possible Fix

    Daemon,

    I found this site that might fix our problem the site is http://atmelwlandriver.sourceforge.net/news.html check it out, I am not at home right now, so I dont know, but there may be hope in that.
    Share on Google+

  7. #7
    Registered User +Daemon+'s Avatar
    Join Date
    Jan 2002
    Location
    RC, Ca
    Posts
    3,406
    humm ill have to check it out

    I also found this that I heard works...sponserd by HP

    dunno

    http://www.hpl.hp.com/personal/Jean_...nux/Tools.html
    Share on Google+

  8. #8
    Registered User
    Join Date
    Aug 2003
    Posts
    13

    RE: Wireless

    Try this link : http://www.linux-wlan.com/linux-wlan/ Also, check to see if the prism2/3 package was loaded on install. If not, try it. If so, uninstall and try the wlan-ng package and compile. Their site has info to help config after the install and some trouble shooting fax. Good Luck!
    Share on Google+

  9. #9
    Registered User +Daemon+'s Avatar
    Join Date
    Jan 2002
    Location
    RC, Ca
    Posts
    3,406

    Re: RE: Wireless

    Originally posted by tazman
    Try this link : http://www.linux-wlan.com/linux-wlan/ Also, check to see if the prism2/3 package was loaded on install. If not, try it. If so, uninstall and try the wlan-ng package and compile. Their site has info to help config after the install and some trouble shooting fax. Good Luck!
    yup tried that..

    it compiles and installs and dtects the card but wont load the card, plus this is one of the worst ones ehhe
    Share on Google+

  10. #10
    Registered User
    Join Date
    Aug 2003
    Posts
    13

    RE: Wireless

    Did you make an "alias eth0" or "alias wlan0"I entry in the modules .conf file? I was able to watch the services load but the card fail during the post. Making the update to the modules.conf file fixed the problem.
    Share on Google+

  11. #11
    Registered User +Daemon+'s Avatar
    Join Date
    Jan 2002
    Location
    RC, Ca
    Posts
    3,406

    Re: RE: Wireless

    Originally posted by tazman
    Did you make an "alias eth0" or "alias wlan0"I entry in the modules .conf file? I was able to watch the services load but the card fail during the post. Making the update to the modules.conf file fixed the problem.
    yeah I did

    then I tryed bringing it up and it would say wlan0 unknown device
    Share on Google+

  12. #12
    Registered User
    Join Date
    Aug 2003
    Posts
    13

    Re: Wireless

    Yea, I still get the same thing. I don't know why but it still loads. What model do you have? I used the same tar ball on my laptop wireless and get the same message but it beeps after the card services and lo and behold, it loads, no problem.
    Share on Google+

  13. #13
    Share on Google+

  14. #14
    Registered User
    Join Date
    Aug 2003
    Posts
    13

    RE: Wireless

    Don't know if this will help you. This is a thread that was sent to me when I was setting up my laptop. It's for a different adapter but the drivers and config are hopefully the same for your Linksys. I ended up using the Orinoco drivers so it didn't pertain to me, but I kept the thread anyway.

    "I have compiled the driver without problems (only the prism2_usb).

    Because the MDK9.1 (not the MDK 9.0) includes already a prism2_usb module,
    I've made a link from "/lib/modules/2.4.21-0.13-mdk/usb/prism2_usb" to
    "/lib/modules/2.4.21-0.13-mdk/kernel/3rdparty/prism2.5/usb/prism2_usb.o".

    I've created an "ifcfg-wlan0" in "/etc/sysconfig/network.scripts" which suites
    to my needs, and adapted the "/etc/wlan/wlan.conf" to my HOME (Ad-Hoc)
    network (with creation of a "wlancfg-HOME").

    When I plug the device, the modules are loaded (p80211 and prism2_usb) but
    nothing else happens.
    I have to type "/etc/init.d/wlan start" and "ifup wlan0" in order to activate
    the device, ... and it works !!

    It seems like if the wlan script (in /etc/init.d/) and the prism2_usb script
    (in /etc/hotplug/usb/) were never execute.
    I've added "alias wlan0 prism2_usb" (with or without "options prism2_usb
    prism2_doreset=1") in my "/etc/modules.conf".
    I've also added "prism2_usb 0x0003 0x09aa 0x3642 0x0000
    0x0000 0x02 0x00 0x00 0xff
    0x01 0x00 0x00000000" in "/etc/hotplug/usb.handmap".
    But the device never initializes itself automatically. I always have to run
    the scripts "by hands".
    Hope this helps.
    Share on Google+

  15. #15
    Registered User +Daemon+'s Avatar
    Join Date
    Jan 2002
    Location
    RC, Ca
    Posts
    3,406
    ok I just got my wireless adpater working man it was fun

    WUSB12 Linksys (USB)
    running slackware 9.0 with custom kernel 2.4.22
    my big problem: didnt have the USB usb-ohci module loaded
    FIles to download - ftp://ftp.linux-wlan.org/pub/linux-w...1-pre11.tar.gz
    ReadMe - ftp://ftp.linux-wlan.org/pub/linux-wlan-ng/README

    fo the fun part.

    FIrst off make sure your USB controller is detected and working, one way I found out was recompiling my kernel with the right usb controller in it, and also checking my boot messages with "dmesg"

    Then I extraced wlan and compiled and installed it
    then I followed these direction from the readme

    ================================================== =====================
    Configuring:

    NOTE: linux-wlan-ng does not fully implement the wireless extensions
    interface. This means that you can't use iwconfig and its kin to
    set things up. Instead, read on!

    As of linux-wlan-ng 0.1.16-pre5, the configuration and launch scripts have
    been largely re-written. pcmcia/rc/hotplug now all use a common library
    of routines and use the same set of configuration files.

    Now, everything relevant exists in /etc/wlan/*

    /etc/wlan/wlan.conf:

    This file maps between wlan devices and network IDs, and contains
    the names of all devices that should be initialized by the hotplug
    and rc scripts.

    /etc/wlan/wlancfg-*

    These files are per-network configurations. This makes it easy to
    switch between different SSIDs and the various settings they may
    require, like WEP keys and whatnot.

    The bare minimum you need to do to configure your system after a fresh driver
    install:

    0) Nothing whatsoever. out-of-the-box, the driver will attempt to associate
    with any access point within range.

    However, we highly recommend setting up a configuration specifically for
    your network, using the following method:

    0) This example assumes your network name/SSID is "MyHomeNetwork"
    1) cp /etc/wlan/wlancfg-DEFAULT /etc/wlan/wlancfg-MyHomeNetwork
    2) edit /etc/wlan/wlan.conf and change the SSID_wlan0 line to:
    SSID_wlan0="MyHomeNetwork"
    3) edit /etc/wlan/wlancfg-MyHomeNetwork, and make any necessary changes
    necessary to support your network, such as WEP and whatnot.
    ------------------------------
    FOR PCI, PLX, OR USB USERS:
    A) You must make sure that the drivers get loaded at boot time and that the
    necessary initialization takes place. The simplest way to do this is
    to add the following commands to your rc.local file:

    modprobe prism2_pci [or prism2_usb/prism2_plx]
    wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable
    wlanctl-ng wlan0 lnxreq_autojoin ssid=<your APs SSID> authtype=opensystem
    ifconfig wlan0 <yourIP> netmask <yourNetmask> broadcast <yourBroadcast>
    route add default gw <yourGateway>

    Also, don't forget to set up your resolv.conf to point at your DNS server.

    B) Alternatively, you can use the rc.wlan script, which ties into the
    /etc/wlan/* configuration files mentioned above.

    We currently don't create the softlink from the runlevel directories to
    the wlan startup script due to differences in distributions, but the
    scripts are redhat-aware, and can be extended to hook into other tools
    easily. (patches welcome!) Just make sure it is brought up early in
    the process, namely, before the the network interfaces are brought up.

    C) Add an alias for wlan0 in /etc/modules.conf. For example, a usb
    interface on wlan0 would be set up as:

    alias wlan0 prism2_usb

    Substitute prism2_plx or prism2_pci as appropriate.

    ------------------------------
    FOR USB USERS:

    A) Make sure your kernel usb support is running
    B) Plug in the Prism2.x USB device
    C) Run 'modprobe prism2_usb prism2_doreset=1' to load the driver into memory.
    D) Run 'wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable' to initialize the
    driver+MAC functions.
    E) Run 'wlanctl-ng wlan0 lnxreq_autojoin ssid=<your ssid> authtype=opensystem'
    to enable the MAC in Infrastructure Station mode.
    F) Run 'ifconfig wlan0 <your IP address>'

    Or, you can use the provided hotplug scripts, if your distribution has
    hotplug support.

    IMPORTANT: Due to an issue with some versions of the Prism USB firmware,
    the driver usually needs to perform a port reset.

    Some combinations of usb low-level drivers, kernel releases, and
    hardware don't like this, and usually end up generating a kernel OOPS.
    newer kernels are much better in this regard. In particular, Intel usb
    controllers are the most trouble-prone.

    The OOPS is due to bugs in the linux USB core, and newer kernels
    (2.4.19 and later) behave much better in this regard.

    However, the good news is that primary firmware 1.1.2 seems to resolve
    the need for the port reset to begin with. Contact your vendor to
    request this update.

    Also, using the 'Alt. UHCI' controller driver (uhci.o) is broken with
    kernels older than 2.4.22 due to a bug in the controller driver.
    ------------------------------------------

    to make sure the prism2_usb is loaded you can type "lsmod" to see the modules loaded
    NOTE: when you follow the readme, make sure you dont use the prism2_PCI, use the prism2_USB

    hope this helps

    any questions please post ill try to help
    Share on Google+

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •