USB memory stick
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 22

Thread: USB memory stick

  1. #1
    Registered User
    Join Date
    Dec 2003
    Location
    Perth, Ontario
    Posts
    14

    USB memory stick

    I have had a problem using USB memory sticks (3 brands, 4 capacities) on an ASUS P4P800 motherboard. Scanners, cameras, printers all work on all USB ports, but USB memory sticks all cause lockups (using any port) in My Computer until the device is disconnected. If the drivers are removed (WinXP Device Manager) and the stick is reinserted, it is detected, but a message comes up saying that the installation was not successful, and the device will not likely work (which is true).

    I think I have to either have to reinstall WinXP home, or delete the drivers that are specific to USB memory sticks and reinstall them from the WINXP CD, but I don't know which files to delete.

    Thanks for any ideas.

    John

  2. #2
    Driver Terrier NooNoo's Avatar
    Join Date
    Dec 2000
    Location
    UK
    Posts
    31,824
    Welcome to Windrivers johnmacf

    What motherboard do you have, sounds like you need motherboard drivers installed.
    Never, ever approach a computer saying or even thinking "I will just do this quickly."

  3. #3
    King of the Mermaids Diver01's Avatar
    Join Date
    Mar 2000
    Location
    Minnisoooda (cold wasteland)
    Posts
    1,443
    I have same MB and I use a USB memory stick. I do have the latest BIOS as well. Also check and make sure that you have installed all Windows Update Patches ect...
    If all of that is ok, you probably have a corrupt registry.
    W

  4. #4
    Registered User
    Join Date
    Dec 2003
    Location
    Perth, Ontario
    Posts
    14
    Quote Originally Posted by Diver01
    I have same MB and I use a USB memory stick. I do have the latest BIOS as well. Also check and make sure that you have installed all Windows Update Patches ect...
    If all of that is ok, you probably have a corrupt registry.

    The BIOS is up-to-date, and I have installed the USB 2.0 patch from MS. Any idea which registry keys can be removed?

    Thanks for the quick reponse.

  5. #5
    Registered User
    Join Date
    Dec 2003
    Location
    Perth, Ontario
    Posts
    14
    Quote Originally Posted by NooNoo
    Welcome to Windrivers johnmacf

    What motherboard do you have, sounds like you need motherboard drivers installed.

    It's an ASUS P4P800 - Intel chipset. Do you mean the Infinst download from Intel? I haven't tried it yet, but since all USB peripherals work except the memory sticks, I wonder if it will help. I'll give it a try.

    Thanks for your reply

    John

  6. #6
    Driver Terrier NooNoo's Avatar
    Join Date
    Dec 2000
    Location
    UK
    Posts
    31,824
    Quote Originally Posted by johnmacf
    It's an ASUS P4P800 - Intel chipset. Do you mean the Infinst download from Intel? I haven't tried it yet, but since all USB peripherals work except the memory sticks, I wonder if it will help. I'll give it a try.

    Thanks for your reply

    John

    Yep, can't hurt, and sorry I didn't notice you posting your mobo... something to do with too many posts to be read today.
    Never, ever approach a computer saying or even thinking "I will just do this quickly."

  7. #7
    Registered User
    Join Date
    Dec 2003
    Location
    Perth, Ontario
    Posts
    14
    Since the last response, I have done the following:

    1. Updated the BIOS (to 10.14)
    2. Reinstalled WinXPSP1 over itself
    3. Uninstalled the memory stick & USB devices from both the Disk Drive & USB sections of Device Manager - tricky, since the system freezes when a stick is inserted and the device doesn't show up when it isn't.
    4. Done some swearing.

    Result? - nothing. Are there any third party USB memory drivers for WinXP?

    Thanks,
    John

  8. #8
    Registered User
    Join Date
    Dec 2003
    Location
    Perth, Ontario
    Posts
    14
    Sorry, I forgot :

    0. Installed the Intel chipset drivers.

  9. #9
    King of the Mermaids Diver01's Avatar
    Join Date
    Mar 2000
    Location
    Minnisoooda (cold wasteland)
    Posts
    1,443
    XP does not require any drivers at all. The only OS that needs drivers is Win98.

    I am not sure which registry keys are associated with the memory sticks. You may want to try and do a search on your brand of memory stick and see if you can locate the key itself. (If you feel confortable messing with the registry and back it up of course.. )

    You may want to also try a registry cleaner if all else fails, it may not do anything but I cant think of where else the problem is besides in the registry.

    Dont give up, theres got to be a solution somewhere... Someone here has got to know...

    Also, have you tried using the sticks in another PC? Just another thought...
    W

  10. #10
    Registered User
    Join Date
    Dec 2003
    Location
    Perth, Ontario
    Posts
    14
    Quote Originally Posted by Diver01
    XP does not require any drivers at all. The only OS that needs drivers is Win98.

    I am not sure which registry keys are associated with the memory sticks. You may want to try and do a search on your brand of memory stick and see if you can locate the key itself. (If you feel confortable messing with the registry and back it up of course.. )

    You may want to also try a registry cleaner if all else fails, it may not do anything but I cant think of where else the problem is besides in the registry.

    Dont give up, theres got to be a solution somewhere... Someone here has got to know...

    Also, have you tried using the sticks in another PC? Just another thought...
    Yes, all 3 sticks work in many other machines. Ther are 3 sticks in all - an 8MB IBM, an OTI Falcon 128MB, and a 32MB that I don't have the make for.

    I'm aware of the XP driver situation - also true in W2K (& maybe Me), but I was just grasping at straws.

  11. #11
    Driver Terrier NooNoo's Avatar
    Join Date
    Dec 2000
    Location
    UK
    Posts
    31,824
    These sticks all 1.1 ?

    I just shoved my pqi stick in and got the following registry entries - the stick has never been installed on this xp machine, so these are (in theory) clean entries.
    searched for usb mass storage:
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Cl ***\{36FC9E60-C465-11CF-8056-444553540000}\0010


    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\USB\V id_0c76&Pid_0005\5&1784ac4b&0&2

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\USB\V id_0ea0&Pid_6803\39621ED83E9D0226

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\USBST OR\Disk&Ven_GENERIC&Prod_USB_Mass_Storage&Rev_1.00 \6&1c71fce&0

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\U SBSTOR

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control\Cl ***\{36FC9E60-C465-11CF-8056-444553540000}\0010


    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Enum\USB\V id_07b4&Pid_0105\000262029826


    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Enum\USB\V id_0ea0&Pid_6803\20731BE33CBD3AC3

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\U SBSTOR

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Control\Cl ***\{36FC9E60-C465-11CF-8056-444553540000}\0010

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Enum\USB\V id_0ea0&Pid_6803\20731BE33CBD3AC3


    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\U SBSTOR

    Actually there are loads of them - I forgot about my camera, so it has entries for that and it stores them as mass storage devices... so a search for mass storage would work.

    A search for Pqi - which is the name that XP reports my mass storage device as, turns up nothing in the registry.

    If you are going to hack your reg about, then I suggest that you do it in safe mode and take a copy of the reg before you start.
    Last edited by NooNoo; January 9th, 2004 at 07:06 PM.
    Never, ever approach a computer saying or even thinking "I will just do this quickly."

  12. #12
    Registered User
    Join Date
    Dec 2003
    Location
    Perth, Ontario
    Posts
    14
    Quote Originally Posted by NooNoo
    These sticks all 1.1 ?
    None of the sticks are USB 2, so I guess thy're 1.1.

    I'll try the registry search next week & get back to you.

    Thanks,
    John

  13. #13
    Registered User
    Join Date
    Dec 2003
    Location
    Perth, Ontario
    Posts
    14
    Quote Originally Posted by NooNoo
    These sticks all 1.1 ?

    I just shoved my pqi stick in and got the following registry entries - the stick has never been installed on this xp machine, so these are (in theory) clean entries.
    searched for usb mass storage:
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Cl ***\{36FC9E60-C465-11CF-8056-444553540000}\0010


    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\USB\V id_0c76&Pid_0005\5&1784ac4b&0&2

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\USB\V id_0ea0&Pid_6803\39621ED83E9D0226

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\USBST OR\Disk&Ven_GENERIC&Prod_USB_Mass_Storage&Rev_1.00 \6&1c71fce&0

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\U SBSTOR

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control\Cl ***\{36FC9E60-C465-11CF-8056-444553540000}\0010


    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Enum\USB\V id_07b4&Pid_0105\000262029826


    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Enum\USB\V id_0ea0&Pid_6803\20731BE33CBD3AC3

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\U SBSTOR

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Control\Cl ***\{36FC9E60-C465-11CF-8056-444553540000}\0010

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Enum\USB\V id_0ea0&Pid_6803\20731BE33CBD3AC3


    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\U SBSTOR

    Actually there are loads of them - I forgot about my camera, so it has entries for that and it stores them as mass storage devices... so a search for mass storage would work.

    A search for Pqi - which is the name that XP reports my mass storage device as, turns up nothing in the registry.

    If you are going to hack your reg about, then I suggest that you do it in safe mode and take a copy of the reg before you start.
    Sorry to take so long to get back to you. I just had a look at the registry & found similar keys to the ones you describe. There were also entries for a printer with memory card slot, and a camera, as expected. When I tried to delete one of the memory stick keys, after the confirmation message I was told that the key could not be deleted (I was logged on as administrator). I tried the same thing with other keys (there are 3 different sticks that have been used on this machine), with the same results.

    I think it's time to wipe the drive & reinstall.

    Thanks for your help.

  14. #14
    Driver Terrier NooNoo's Avatar
    Join Date
    Dec 2000
    Location
    UK
    Posts
    31,824
    Did you try it in safe mode?
    Never, ever approach a computer saying or even thinking "I will just do this quickly."

  15. #15
    Registered User
    Join Date
    Dec 2003
    Location
    Perth, Ontario
    Posts
    14
    Quote Originally Posted by NooNoo
    Did you try it in safe mode?
    Yes, I used safe mode. The registry and the memory stick both behaved in exactly the same way as they did in normal mode.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •