A7V333 USB 2.0 Issue
Results 1 to 4 of 4

Thread: A7V333 USB 2.0 Issue

  1. #1
    Registered User PacoL250's Avatar
    Join Date
    Nov 2000
    Location
    USA
    Posts
    129

    Question A7V333 USB 2.0 Issue

    This is quite strange, since I never had to deal with it before. I just got an Iomega 40 GB External HDD and and ARCHOS 20 GB MP3 player both of which support USB 2.0. My motherboard is an ASUS A7V33 which supports USB 2.0. (More Info on the mobo here: http://usa.asus.com/prog/spec.asp?m=A7V333&langs=09)

    Now here's the issue, whenever I plug in either device (I've tried all 4 ports), WinXP Pro says "A high speed USB device plugged into a non-high speed USB port/hub" (or something to that effect). But it doesn't make any sense since both devices work fine on my USB 2.0 PC Card in my laptop. I can use them on my desktop, but without USB 2.0 capabilities. I have downloaded the latest Windows Updates, and I have the latest non-BETA BIOS for my mobo.

    So what could be wrong? I don't see if there's anything I need to do with my BIOS since the ports work fine at USB 1.1, but they don't seem to work at USB 2.0.

    Any ideas?
    "I am an expert of electricity. My father occupied the chair of applied electricity at the state prison." - WC Fields

  2. #2
    Driver Terrier NooNoo's Avatar
    Join Date
    Dec 2000
    Location
    UK
    Posts
    31,844
    Paco, in device manager, exactly what is listed for usb hubs and controllers?

    Do you have XP SP1 loaded?
    Never, ever approach a computer saying or even thinking "I will just do this quickly."

  3. #3
    Registered User hudsonsmith's Avatar
    Join Date
    Feb 2003
    Location
    New York
    Posts
    2,276
    VIA has a usb2 driver package which "can be installed after Microsoft driver to further improve device compatibility." http://downloads.viaarena.com/driver...2_V258p3-L.zip
    Probability factor of one to one...we have normality, I repeat we have normality. Anything you still can't cope with is therefore your own problem.

  4. #4
    Registered User
    Join Date
    Jun 2004
    Posts
    1
    Well, maybe ur problem is not quite the same, but i'll explain mine anyway ... and of course how i solved it :P

    I have XP running on an a7v333 for over 2 years now and never (really n-e-v-e-r) had any problems with it. Untill i plugged in a usb2.0 mem-stick... *suspense*

    1. ... the os tells me it detects a fast usb device on a slow usb-connection. Ok, fair enough, updated the via 4in1 drivers - already had xp sp1 installed. And while i am updating i go have a look at asus to check my bios ... ah, i have the latest stable version (v1017) so i'll just leave the bios be.

    asus a7v333 downloads @
    http://www.asus.com.tw/support/downl...delName=A7V333

    4in1 drivers for win @
    http://www.viaarena.com/?PageID=403

    2. Restarted, plugged mem-stick back in ... os doesnt detect it. Ow well, i'll just pull the usb-stick out ... erm, y does my computer reboot all off a sudden?! This is getting nasty :/ Ok, think positive, i'll go ask our friend google. So i find the usb2.0 driver package for xp on the via website.

    Usb2.0 for xp @
    http://www.viaarena.com/?PageID=298

    3. No change - my box still reboots when i pull out the usb-stick. This isn't getting any better. What on earth is this usb2.0 doing to my faithfull mobo? Aaaargh. Have the latest drivers for xp so i rule out the os ... let's check my bios again. Instead of navigating to the asus-site, i decide to use the (btw excellent) bios-update-utility from asus to get the latest bios-version. It gives me 2 options: 1017 (final) or 1018 (beta). WTF? 1017? I have that version! *puzzled*

    4. I am a bit reluctant to install a beta for the bios of my (once) stable pc, so i doublecheck v1017. Turns out mine is of an earlier date than the final one. Soooooo ... i update my bios to 1017 (final) with the windows-utility, rebooted and reinstalled the via usb2.0 drivers for xp. FIXED!

    bios-update-utility (= ASUS update) @
    http://www.asus.com.tw/support/downl...odelName=Tools


    Moral of the story:
    Be sure to have xp sp1 installed, coz it enables usb2.0 support, update to the latest bios and install the via usb2.0 drivers afterwards.


    I hope this fixes your problem and of many other peeps, coz i could only find a couple - 2 or 3 - webpages featuring the same problem. None of them mentioned this v1017 bios-discrepancy.

    Btw, stick to this mobo, definitely stable and pretty fast.

    *******
    And to be complete, my basic hardware-config:
    mobo asus a7v333
    cpu amd 2000xp 266fsb
    gfx asus gf5200-td
    hdd maxtor 120GB 7200/133
    mem 512 ddr 333

Similar Threads

  1. USB 2.0 Mass Storage Device on 2.0 Port Uses 1.1
    By geschmidtt in forum USB/Firewire
    Replies: 3
    Last Post: May 19th, 2004, 04:05 AM
  2. Another PCMCIA USB 2.0 Cardbus Problem
    By Rankinfile in forum USB/Firewire
    Replies: 6
    Last Post: May 5th, 2004, 02:00 AM
  3. usb2.0 and firewire combo on laptop
    By crazyzoop84 in forum USB/Firewire
    Replies: 12
    Last Post: April 15th, 2004, 06:09 AM
  4. Nice Toy
    By firemonkey in forum Tech Lounge & Tales
    Replies: 3
    Last Post: October 7th, 2003, 12:46 AM
  5. USB 2.0 problems
    By MacGyver in forum USB/Firewire
    Replies: 9
    Last Post: December 21st, 2002, 02:39 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •