bios doesn't detect cd/dvd drive! help me plz!!
Results 1 to 6 of 6

Thread: bios doesn't detect cd/dvd drive! help me plz!!

  1. #1
    Registered User
    Join Date
    Aug 2009
    Posts
    2

    Exclamation bios doesn't detect cd/dvd drive! help me plz!!

    hi, since a couple of weeks my cd/dvd drive has disappear from my computer, after i did some research i delete the upper and lower filters in the registry editors, which didn't work, so i went further, i reformat my computer and it didn't
    fix problem, then i noticed that sometimes it occasionally works but after a restart i would stop working, so then i went to bios and notice that theres was no drive in cd/dvd , so i replaced the cd/dvd drive of another laptop to mine and i put mine to the other laptop, and it still didn't show up but my cd/dvd drive showed up in the other laptop, so then i though it was a bios problem, so i updated my bios and it still didn't fix my problem. so i need help from someone plz!!!Help me plz!!


    this are my pc specs:

    Windows edition
    Windows Vista Home Premium
    Copyright 2006 Microsoft Corporation. All rights reserved

    System
    Manufacter: Acer
    Model: Aspire 5520
    Processor: AMD Athlon(tm) 64 X2 Dual-Core Processor TK-53 1.70GHz
    Memory(RAM): 2815 MB
    System type: 32-bit Operating System

  2. #2
    Registered User
    Join Date
    Feb 2006
    Location
    Canada, Eh!
    Posts
    4,085
    Check the integrity of the IDE cable/cable connections - this may require dismantling so, if the unit is under warranty, have them do it.

    edit: this isn't, apparently, a rare issue; http://74.125.93.132/search?q=cache:...&ct=clnk&gl=ca
    Last edited by CCT; August 24th, 2009 at 06:59 AM.

  3. #3
    Registered User
    Join Date
    Aug 2009
    Posts
    2
    well thanks for the reply.my warranty expired a year ago, so i did dismantle it myself and there are no IDE cable/cable, the cd/dvd drive is connected in the motherboard, my computer is a laptop. i cleaned the connector but after i put everything back, nothing happen, the laptop is still as it has been the last 2 months, any other ideas?????..

  4. #4
    Registered User Ferrit's Avatar
    Join Date
    Apr 2001
    Location
    Vancouver Island The Real Canada
    Posts
    4,911
    Something is wrong with the connection in the laptop between the dvd drive and the motherboard.
    Sounds like it may not be seating deep enough to make proper full time contact
    Gigabyte 990FXA-UD3
    AMD FX 8350 4ghz OCTO-Core
    Windows 8.1 PRO 64
    Adata 256 gig SSD
    Kingston HyperX 1600 16 Gigs
    Sapphire R9 280 2gig
    Enermax Liberty Modular 620
    www.northernaurora.net
    http://www.northernaurora.net/page/chat.html

  5. #5
    Registered User
    Join Date
    Feb 2006
    Location
    Canada, Eh!
    Posts
    4,085
    It is also very probable that the CD drive died - this happens.

    Laptops are hard to work with online since many suggestions cannot work without a friend with almost the exact same laptop to test things out.

    Sometimes the 'shop' is the best answer, even if it costs.

  6. #6
    Registered User
    Join Date
    Sep 2009
    Location
    Buenos Aires, Argentina
    Posts
    1
    I've fixed this issue (sometimes the bios/sys/win "see" the drive and sometimes not), all that I did is dismantle my laptop (Acer 3100), yes almost completely, take the mother and with a soldering iron retouch each pin of the ide conector in the Mother.. so far , so good..
    I didn't add lead, can be fatal if you don't have years of expertise soldering, if you think you really need that, try it as a second chance, with a 20W well sharped iron, and a very thin lead.... just in case you messed up shorting the pins with lead, use a desoldering wick and patience,and re-solder, otherwise you can damage you mother. Anyway, just reheating should work.

    Saludos.

Similar Threads

  1. Replies: 21
    Last Post: February 11th, 2008, 02:31 PM
  2. BIOS recovery tips (updated topic)
    By Ruslan in forum Tech-To-Tech
    Replies: 29
    Last Post: June 21st, 2004, 04:06 AM
  3. [RESOLVED] Bios size recognition of Hard Drive
    By kmccoy in forum Tech-To-Tech
    Replies: 3
    Last Post: May 9th, 2002, 12:38 AM
  4. [RESOLVED] Bios size recognition of Hard Drive
    By kmccoy in forum Tech-To-Tech
    Replies: 2
    Last Post: May 8th, 2002, 02:12 PM
  5. [RESOLVED] Bios does not detect hard drive
    By Robert25 in forum BIOS/Motherboard Drivers
    Replies: 11
    Last Post: August 2nd, 2000, 12:07 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •