USB Device Not recognised
Results 1 to 6 of 6

Thread: USB Device Not recognised

  1. #1
    Registered User
    Join Date
    Jan 2005

    USB Device Not recognised

    Any help will be much appreciated.

    System :-

    Toshiba tecra 9000
    MS XP SP2 with latest updates

    Problem :-

    About 7 days ago (for no obvious reason) no hardware had been added/changed, the last SP2 updates were 15th December, no other software/drivers had been added/changed, I started to get an error message 'One of the USB devices attached to this computer has malfunctioned and windows does not recognise it.' every time a USB device is plugged into either of the 2 USB ports.

    The devices I have are

    Logitech USB Mouse
    Iomega 7 in 1 Floppy drive and card reader
    Newlink 4 port powered USB hub
    Iomega 52 X 24 X 52 CD/RW
    Newlink 256 MB memory stick
    LaCie 160 GB external HD
    Fuji Finepix 6800 camera cradle

    I have borrowed and HD (with XP no SP2 on it) and changed it with the HD on my laptop - all the USB devices work just fine. This says to me the Devices are OK, the drivers (that are required) are OK for XP and the USB ports on the laptop are OK.

    When using my HD with XP SP2 + Updates, all of the USB devices are listed in Device Manager.

    Intel 82801CA/CAM USB Universal Host Controller -2482
    Intel 82801CA/CAM USB Universal Host Controller - 2484
    Intel 82801CA/CAM USB Universal Host Controller -2487

    USB Root Hub
    USB Root Hub
    USB Root Hub

    The Host Controllers are using the Microsoft Drivers :-


    File version 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)

    The Root Hubs are using the Microsoft Drivers:-


    File version 5.1.2600.0 (xpclient.010817-1148)

    Any device plugged into a USB port shows the error message above and the device is shown in Device Manager as Unknown Device. If you look at Driver Details in Device Manager, a dialog box opens saying 'No driver files are required or have been loaded for this device'.

    I have tried deleting all USB devices and let XP reload the Host controllers and Root Hubs. I have deleted and reloaded the USB device drivers (for those that have them). I have started in safe mode.

    It seems to me that XP SP2 with updates is not recognising the USB devices properly and is not loading the correct drivers.

    Any help, suggestions,advice would be greatly appreciated. I am stuffed without USB support and have ordered a PCMCIA /USB card hoping it will give me a short term solution.

    Best regards.

  2. #2
    Registered User Richard1's Avatar
    Join Date
    Oct 2003
    East Coast
    The first thing I would do is roll back Service Pack 2. Ensure that this is the root of the problem. Sometimes hardware can just goes bad. Most likely it will be SP2 but you want to be sure before you start changing stuff.

    You may also try updating your bios, although I'm not quite sure whether that will help or not. Good luck.

  3. #3
    Registered User
    Join Date
    Feb 2006

    Im having the same sort of problem!!


    I have a very similar problem and have tried all the things you said..

    One day everything was working properly and then I plaugged in another external harddrive.. something I had been doing all the time and all my external hard drives became unrecognised.

    Whats strange is that my USB mouse is fine.. I tried it in all four ports and its ok.. My digital camera also works fine. But i have 3 external hard drives and a 512K memory stick all now do not get recognised..

    I have even tried re-installing Xp pro and SP2 + extras (not a clean install I should add, as I really didn't want to have to rebuild my laptop..)

    Did you ever get a solution..? If anyone out there can suggest anything please let me know...

  4. #4
    Registered User
    Join Date
    Mar 2006
    Did anybody get resolution to this problem? I just loaded winXP Proff SP2 on a newly built PC. All is working fine, except when I try to install a USB Device. The system reconized the manufacturer of the device and starts the driver update. If I find all the right INF/DLL/etc files, Device manager shows the device as not working properly. The load of XP a new disk as of Jan-06.

    Any help would be appreciated!


  5. #5
    Registered User
    Join Date
    Feb 2006
    Canada, Eh!
    I had to turn my USB support on in my bios. Worth looking anyway.


  6. #6
    Registered User
    Join Date
    Mar 2006

    USB devices not reconized

    Thanks for the help.

    After reading a whole bunch of things, I reloaded XP over my previous load. Much to my amazemente, the drivers in questions all were squared away when done. My BIOS was set up prior to the second XP load, but not the original load. XP Must have reconized the proper drivers second time around.

    Thanks again for all of your help!

Similar Threads

  1. USB Device not recognised
    By Chimaera_Trev in forum Windows XP
    Replies: 4
    Last Post: October 9th, 2007, 10:31 PM
  2. USB device error taking me to the edge
    By gusty in forum USB/Firewire
    Replies: 4
    Last Post: March 13th, 2006, 12:09 PM
  3. Can't install USB mass storage device on WIN2000
    By gstonegt in forum USB/Firewire
    Replies: 3
    Last Post: January 28th, 2005, 02:36 PM
  4. PCMCI - USB 2.0 & USB 2.0 external hard
    By Marinero in forum USB/Firewire
    Replies: 14
    Last Post: May 8th, 2004, 07:23 AM
  5. usb2.0 and firewire combo on laptop
    By crazyzoop84 in forum USB/Firewire
    Replies: 12
    Last Post: April 15th, 2004, 06:09 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts