My Western Digital 500GB HD is not cooperating
Results 1 to 2 of 2

Thread: My Western Digital 500GB HD is not cooperating

  1. #1
    Registered User
    Join Date
    Jun 2009

    Unhappy My Western Digital 500GB HD is not cooperating

    Hello there,
    I was wondering if anyone knew how to help me.

    I have some pretty important information on my hard drive I bought last year and in the process of cleaning it out I accidentally deleted some hidden files that I imagine were not suppose to be deleted...

    My computer will now not even recognize it as a valid drive. It will not show up in My Computer, Devise Management, Computer Management/Disc Management nor the Western digital freeware that I downloaded (Data Lifeguard Tools, WinDLG). It is not recognized in Acronis Disc Editor, nor [email protected] Partition Recovery Enterprise.

    I have also tried retrieving the deleted hidden folder with the program PC Inspector File Recovery, and DiscInternals Uneraser... with no luck.

    The drive still acts like it is fine for I can hear it spinning and when I boot it is partially there.
    When scanning hard drives it says: IDE Channel2 Slave - S_ATA2 -

    part of the information is missing because my other drive that is fine says:
    IDE Channel2 Master - S_ATA1 - WDC WD800JD-0

    When I enter BIOS the same message

    Channel2 Master [S_ATA1 - WDC WD800JD-0]
    Channel2 Slave [S_ATA2]

    Can anyone help me with this disastrous predicament? I am in dire need of a genius computer technician!!!!

    The Make is Western Digital WD5000AAKS
    a WD Caviar SE16
    MDL : WD5000AAKS - 65TMA0
    Date : 27 April 2007

  2. #2
    Driver Terrier NooNoo's Avatar
    Join Date
    Dec 2000
    Welcome to Windrivers Sethward

    Well it looks like you tried the obvious... did you start the data lifeguard tools from within windows or did you boot from the CD? If you tried only from windows then you should boot the datalifeguard cd. On top of that there is couple of things I would try

    1. See if you have more than 2 SATA ports, if you have, plug the drive into the 3rd or 4th port
    2. Remove the drive and get a USB to SATA connector and try and get to recognise as a usb drive.

    There might be a problem with the sata cable or the sata controller you are using.
    Never, ever approach a computer saying or even thinking "I will just do this quickly."

Similar Threads

  1. Replies: 0
    Last Post: September 15th, 2007, 04:38 AM
  2. Replies: 2
    Last Post: May 16th, 2007, 01:33 PM
  3. HD NEWS: Western Digital Raptor WD1500 Review
    By TechZ in forum Tech News
    Replies: 1
    Last Post: January 6th, 2006, 04:49 AM
  4. Replies: 4
    Last Post: June 3rd, 2001, 09:38 AM
  5. [RESOLVED] Western Digital HD compatibility with ABIT BE6 Motherboard
    By ab2dz in forum Hard Drive/IDE/SCSI Drivers
    Replies: 3
    Last Post: February 17th, 2000, 12:09 AM

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts